Issues with phone support.
Incident Report for StackPath
Resolved
Our team have setup new phone numbers to circumvent the third-party issues that caused this incident. Moving forward, please use the below phone numbers to contact Highwinds Support, Sales, Accounting, and Billing teams.

1-800-570-2253 (USA Toll Free)
+1 469-929-2795 (International)
Posted Oct 20, 2017 - 18:10 UTC
Update
Incoming calls to our toll-free Customer Support number are still failing to connect to our Support, Sales and Billing teams. Our third-party provider continues to troubleshoot this issue. Please continue to contact us directly at 469-909-5162.
Posted Oct 19, 2017 - 19:50 UTC
Identified
Issue has been identified, until its fully resolved please use following number to reach out : 4699095162.
Posted Oct 14, 2017 - 21:12 UTC
Investigating
The support phone line is having issues at the moment. We are investigating the issue.
Posted Oct 14, 2017 - 19:54 UTC