Support over phone issue
Incident Report for StackPath
Resolved
Our phone system is confirmed to be working normally.
Posted Apr 17, 2018 - 01:44 UTC
Investigating
Investigating - We are currently experiencing issues with our toll free and local phone support numbers. If you would like to speak with a representative, please submit a ticket and provide your account number and call back number. We apologize for the inconvenience and will call you back as soon as possible.
Posted Apr 01, 2018 - 10:28 UTC